首页    新闻    下载    文档    论坛     最新漏洞    黑客教程    数据库    搜索    小榕软件实验室怀旧版    星际争霸WEB版    最新IP准确查询   
名称: 密码:      忘记密码  马上注册
漏洞公告 :: 最新漏洞公告

phpMyAdmin sort_by参数远程代码执行漏洞


http://www.gipsky.com/
phpMyAdmin sort_by参数远程代码执行漏洞

发布日期:2008-09-15

更新日期:2008-09-17



受影响系统:



phpMyAdmin phpMyAdmin < 2.11.9.1



不受影响系统:



phpMyAdmin phpMyAdmin 2.11.9.1



描述:BUGTRAQ ID: 31188



phpMyAdmin是用PHP编写的工具,用于通过WEB管理MySQL。







phpMyAdmin的server_databases.php脚本没有正确地过滤对sort_by参数的输入,远程攻击者可以通过提交恶意请求注入并执行任意PHP代码。



<*来源:Norman Hippert



链接:http://secunia.com/advisories/31884

http://www.phpmyadmin.net/home_page/s ... ty.php?issue=PMASA-2008-7

http://fd.the-wildcat.de/pma_e36a091q11.php

*>



测试方法:<font color='#FF0000'><p align='center'>警 告



以下程序(方法)可能带有攻击性,仅供安全研究与教学之用。使用者风险自负!</p></font>http://www.example.com/server_databas ... ts=0%26amp;sort_by="]) OR exec(%26#39;cp $(pwd)"/config.inc.php" config.txt%26#39;); //%26amp;sort_order=desc%26amp;token=[valid token]



建议:厂商补丁:



phpMyAdmin

----------

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:







http://cache.gmane.org//gmane/comp/se ... y/oss/general/947-001.bin
<< Unreal引擎失败内存分配远程拒绝服务漏洞 Apple Mac OS X 2008-006更新修复多个安全漏洞 >>
评分
10987654321
API:
gipsky.com & 安信网络

系统导航

 

Copyright © 2001-2010 安信网络. All Rights Reserved
京ICP备14013333号-8